Running on a Transparent pfSense Bridge

Follow

Comments

2 comments

  • Avatar
    Gabre Kemp

    Hello. I came across your article while searching for a way to run pfsense as a transparent bridge between my edgerouter x and the switch. I followed your steps up to the point where I enable the OPT1 interface and then have to assign an IP address to the OPT1 interface. I don't know what I'm doing wrong, I want to have the PC running Pfsense at 192.168.2.2 with my gateway (edgerouter X) at 192.168.2.1. When I clck save I get:

    IPv4 address 192.168.2.1/24 is being used by or overlaps with: LAN (192.168.2.2/24) 

    when setting up pfsense I selected 192.168.2.2 as where my LAN DHCP starts

    thank you

  • Avatar
    Arthur Wiebe

    Hey @Gabre Kemp,

    It sounds to me like you're assigning an IP to the bridge interface (OPT1) that is still assigned to the LAN.

    Try assigning a different IP to OPT1, enable it. Then make sure IP configuration type is set to None on both LAN and WAN. Once that is applied and verified you should be able to set the IP you want on OPT1.

    Note you won't be able to set IP configuration type to None unless DHCP is disabled. If you want to run DHCP on pfSense you'll have to enable it on the bridge interface after it's configured.

Please sign in to leave a comment.